本站目前升级了全新主题zhime,该主题色彩更清新明亮。售价99元/套,你值得拥有,后台配置全,永久更新。另外还有Next.js版本!😃

万网虚拟主机解决不支持SMTP发送邮件/您的主机禁用了mail()函数的方法

错误提示:

无法发送电子邮件

可能原因:您的主机禁用了mail()函数

解决办法:

打开wp-includes/class-smtp.php文件,大约202行找到:

$this->smtp_conn = @stream_socket_client(

$host . “:” . $port,

$errno,

$errstr,

$timeout,

STREAM_CLIENT_CONNECT, $socket_context

);

然后将上面这条代码注释或者删除都可以,完成后加入下面这条代码:

$this->smtp_conn = fsockopen($host, $port, $errno, $errstr);

最后,在虚拟主机控制台开启fsockopen函数即可。

读完了点一下,作者能得积分

赞赏

如果这篇内容帮到了你,不妨请作者喝杯咖啡

分享 微博 QQ

4 条评论

发表评论